Boost logo

Ublas :

From: Andreas Klöckner (lists_at_[hidden])
Date: 2008-04-12 18:49:50

Hi Erwann,

On Samstag 12 April 2008, erwann rogard wrote:
> 2) and extracted it in /tmp
> boost-bindings apparently contains
> /boost
> /libs
> some install files
> 3) ran
> /tmp/boost-bindings$ ./configure
> /tmp/boost-bindings$ make
> /tmp/boost-bindings$ make install
> which apparently copies boost-bindings/boost to /usr/local/include

At this point, you're done. The library is installed, as it only consists of
headers and doesn't need to be compiled.

> previously I ran into the problem that *.h were not copied, but now they
> are, thanks -apparently- to a new make script.
> 4) /tmp/libs/ contains
> /numeric
> Jamfile

You can safely ignore those until you feel something is wrong--they're unit
tests. There probably is a way of running them automatically if the bindings
are unpacked as part of the boost tree, but I haven't yet figured out how to
make them work independently.

If anybody can provide guidance on that, I'd be grateful btw.

> Not very familiar with bjam but installed and tested it (the hello example)
> anyway. What do i do now? I tried
> /tmp/boost-bindings/libs$ bjam
> error: Could not find parent for project at '.'
> error: Did not find Jamfile.jam or Jamroot.jam in any parent directory.

Yeah, that's probably due to the missing boost root, see above.