Boost logo

Ublas :

Subject: Re: [ublas] Is coordinate_matrixelement assignment/insertion broken in 1.42?
From: Jesse Perla (jesseperla_at_[hidden])
Date: 2010-02-28 21:05:15

Rutger ter Borg <rutger <at>> writes:
> The trunk of Boost is at, but I

Just to triple-check that I hadn't made any bad patches to ublas, I ran the
test against the trunk and had the same results (failure for MSVC2008SP1 on
win32 and win64, MSVC2010beta2, Intel 11.1.060, and success on mingw.... and
I tried on 2 different machines)

It looks to me like some weird problems are happening with the
sorting/binary search of elements on element access rather than on setting
the values. However, after setting a value a flag tells the matrix to
re-sort upon next access. But I am having trouble tracking down... any ideas
on this?. The new test file that I am attaching gives a little more detail
on the tracking down the problem. I am also attaching the output on mingw
and intel 11.1.

Also, in case there is some weird compiler setting, I have attached my
CMakeCache.txt (CMake 2.8) so you can see my flags if you are curious about