Boost logo

Ublas :

Subject: [ublas] Does uBLAS work with dd_real and qd_real ?
From: Ralf Denzer (Ralf.Denzer_at_[hidden])
Date: 2010-03-26 14:45:05

Hi Paul, 


ok, I working sometimes with ublas::matrix<qd_real>.

For me, qd_real works quite well. I never

entcountered problems using ublas and qd_reals

until now. But I remember, that I changed something 

in the constructor of qd_reals.


If you would be more specific which kind of problems

you have and provide a small test program I could 

have a look.


Btw, there is a newer version, qd-2.3.9, at

but qd-2.3.7 worked for me too.






PS: I set the values of all 4 doubles in

the constructor explicitely to zero. This was

needed for vector.clear() and matrix.clear().


cd qd-2.3.9/include/qd
modify qd_inline.h
/********** Constructors **********/
inline qd_real::qd_real() { }


inline qd_real::qd_real() {
x[0] = x[1] = x[2] = x[3] = 0.0;

One should do the 'same' for dd_real.





Hi all,
Has anyone here worked with dd_real or qd_real (from qd-2.3.7 ) and uBLAS? My testing of these classes in
the context of GluCat has resulted in peculiar errors in matrix results that
look like they occur somewhere within uBLAS matrix multiplication (or possibly
other operations) for matrix< dd_real, row_major > dense matrices.

Is there a test suite I could use to narrow down the cause of the errors, or
are there any known errors in the use of uBLAS with high and arbitrary
precision floating point?
Thanks, Paul

WEB.DE DSL: Internet, Telefon und Entertainment für nur 19,99 EUR/mtl.!