Boost logo

Ublas :

Subject: Re: [ublas] bindings for ScaLAPACK
From: Milosz Kukla (miloszkukla_at_[hidden])
Date: 2010-05-19 00:39:11

Thank you for answer Thomas.Most of undefined references has disappered however some MPI problems are still there. Unfortunatly I dont know what is wrong because I have MPI libs in ldconfig. Perhaps do you have some idea please? I have posted errors here:

Thank you a lot and best wishes,

Dnia 11 maja 2010 15:36 Thomas Klimpel <Thomas.Klimpel_at_[hidden]> napisał(a):

> Milosz Kukla wrote:
> > I tried to change call names adding
> > P letter to functions in lapack_names.h however during compile attemp I
> > got errors on linking time. You can look at it here. Perhaps you had
> > some idea why it happens.
> > <>
> Well, your link line definitively doesn&#039;t follow the mkl recommendations:
> <>
> - First of all, you didn&#039;t tell mkl which mpi version it should use for scalapack
> (for example "-lmkl_blacs_intelmpi_lp64").
> - And second, you decided that the "-Wl,--start-group ... -Wl,--end-group" can savely be ommited.
> I tried to guess your configuration, and this is what the link line advisor told me:
> -L$MKLPATH -lmkl_scalapack_lp64 $MKLPATH/libmkl_solver_lp64.a -Wl,--start-group -lmkl_intel_lp64 -lmkl_gnu_thread -lmkl_core -lmkl_blacs_intelmpi_lp64 -Wl,--end-group -fopenmp -lpthread
> Perhaps you can get some inspiration from that link line.
> Regards,
> Thomas
> _______________________________________________
> ublas mailing list
> ublas_at_[hidden]
> Sent to: miloszkukla_at_[hidden]