please just rename it to BOOST_UBLAS_NOT_USED.


On 10/20/2014 03:13 AM, David Bellot wrote:
Hi Joaquim,

sure, it sounds like a good idea. Whenever your patch is ready, please submit a pull request on ublas/develop. It's open again for changes towards 1.58


On Sat, Oct 18, 2014 at 1:21 AM, Joaquim Duran <> wrote:
I would like to clear some warning that appears when compiling the
tests and benchmarks and improve code organization:

1 - add a macro named NOT_USED (in utils.hpp) to mark tell to the
compiler that a variable that has been assigned a value, it 'll not be

#define NOT_USED(x) (void)(x)

matrix m, a, b;
m = a * b;

NOTE: some tests already avoid this warning.

2 - Remove unused parameters, specially to 'main' functions.

3 - Three tests uses the template function mean_square. This function
could be placed to a header file.

Joaquim Duran
ublas mailing list
Sent to:

ublas mailing list
Sent to: