|
Boost : |
From: vesa_karvonen (vesa_karvonen_at_[hidden])
Date: 2002-01-22 08:02:55
--- In boost_at_y..., "David Abrahams" <david.abrahams_at_r...> wrote:
[...]
> > I still think that the macro names are too long, but...
>
> I would be willing to drop the _PP, as well. I have no problem with
> that: ALL_CAPS names are implicitly preprocessor symbols, and I
> have no problem at all saying that all other libraries (which
> aren't /about/ using the preprocessor after all), should use some
> kind of namespacing for all preprocessor symbols, e.g.
> BOOST_PYTHON_xxxxx.
I like this idea.
The config library has two macros that have overlapping functionality
with the preprocessor library. Namely:
BOOST_JOIN(X,Y) == BOOST_PP_CAT(X,Y)
BOOST_STRINGIZE(X) == BOOST_PP_STRINGIZE(X)
Looking at BOOST_JOIN(X,Y) I notice that the implementation is
slightly different. I think that the BOOST_JOIN(X,Y) version is, in a
sense, more correct.
Why isn't the BOOST_STRINGIZE(X) macro constructed to allow macro
replacement of macro arguments?
At any rate, I think that the functionality belongs in the
preprocessor library (rather than the config library).
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk