Re: [Boost-bugs] [Boost C++ Libraries] #5027: Extension of Boost.Range algorithms

Subject: Re: [Boost-bugs] [Boost C++ Libraries] #5027: Extension of Boost.Range algorithms
From: Boost C++ Libraries (noreply_at_[hidden])
Date: 2011-01-03 16:55:33


#5027: Extension of Boost.Range algorithms
--------------------------------------------+-------------------------------
  Reporter: gast128 <gast128@…> | Owner: neilgroves
      Type: Feature Requests | Status: new
 Milestone: To Be Determined | Component: range
   Version: Boost 1.45.0 | Severity: Not Applicable
Resolution: | Keywords:
--------------------------------------------+-------------------------------

Comment (by neilgroves):

 The xxx_if versions of algorithms are all redundant due to the filtered
 Range Adaptor. Please see the Range Adaptor documentation. The best part
 of the Range Adaptor design, which I believe was first brought up by Eric
 Niebler is that we can easily compose the filter onto any algorithm. This
 is a far better separation of concerns than we see in the standard C++
 library where we have only the most common use-cases covered by _if
 suffixed functions. I believe that Thortsen Ottosens' comment that the
 copy_if algorithm is '... thoroughly mis-designed' is very true. The Range
 Adaptors are a superior alternative requiring no duplication when writing
 algorithms, provide superior consistency and readability.

 The functions contains, any, all, and none I have frequently wanted and it
 does make sense for this to be available in Boost.

-- 
Ticket URL: <https://svn.boost.org/trac/boost/ticket/5027#comment:2>
Boost C++ Libraries <http://www.boost.org/>
Boost provides free peer-reviewed portable C++ source libraries.

This archive was generated by hypermail 2.1.7 : 2017-02-16 18:50:05 UTC