Re: [Boost-bugs] [Boost C++ Libraries] #11561: Build fails with threading=single, multi

Subject: Re: [Boost-bugs] [Boost C++ Libraries] #11561: Build fails with threading=single, multi
From: Boost C++ Libraries (noreply_at_[hidden])
Date: 2016-02-18 04:08:55

#11561: Build fails with threading=single,multi
  Reporter: ryandesign@… | Owner: vladimir_prus
      Type: Bugs | Status: new
 Milestone: To Be Determined | Component: build
   Version: Boost 1.59.0 | Severity: Problem
Resolution: | Keywords:

Comment (by ryandesign@…):

 The `b2` command line that was used was given in the log file attached to
 the MacPorts bug report linked from the description of this ticket. I'll
 paste it here for easier reference:

 {{{b2 -d2 --layout=tagged --debug-configuration --user-config=user-
 config.jam -sBZIP2_INCLUDE=/opt/local/include
 -sBZIP2_LIBPATH=/opt/local/lib -sEXPAT_INCLUDE=/opt/local/include
 -sEXPAT_LIBPATH=/opt/local/lib -sZLIB_INCLUDE=/opt/local/include
 -sZLIB_LIBPATH=/opt/local/lib -sICU_PATH=/opt/local variant=release
 threading=single,multi link=static,shared -j4 architecture=x86 address-
 model=64 link=shared}}}

 I would not begin from the assumption that the problem is MacPorts-
 specific nor that it is OS X-specific, since, as I said, the problem did
 not exist with boost 1.58.0.

 I have also tried with boost 1.60.0, and the issue remains. I have tried
 with `--debug-building` and have attached the log here.

Ticket URL: <>
Boost C++ Libraries <>
Boost provides free peer-reviewed portable C++ source libraries.

This archive was generated by hypermail 2.1.7 : 2017-02-16 18:50:19 UTC