[Boost-bugs] [Boost C++ Libraries] #12628: Build error with -no_single variant (macports)

Subject: [Boost-bugs] [Boost C++ Libraries] #12628: Build error with -no_single variant (macports)
From: Boost C++ Libraries (noreply_at_[hidden])
Date: 2016-11-28 08:58:37

#12628: Build error with -no_single variant (macports)
 Reporter: anonymous | Type: Bugs
   Status: new | Milestone: To Be Determined
Component: None | Version: Boost 1.59.0
 Severity: Problem | Keywords:
 When installing boost 1.59 with single and multithread on my macOS Sierra
 (10.12.1) using Macports I get the following error:

 error: Name clash for '<pstage/lib>libboost_atomic-mt.dylib'
 :info:build error:
 :info:build error: Tried to build the target twice, with property sets
 :info:build error: these incompatible properties:
 :info:build error:
 :info:build error: - none
 :info:build error: - <dll-path>/opt/local/bin
 :info:build error:
 :info:build error: Please make sure to have consistent requirements for
 :info:build error: properties everywhere in your project, especially for
 :info:build error: targets.
 :info:build Command failed: cd
 -d2 --layout=tagged --debug-configuration --user-config=user-config.jam
 -sBZIP2_INCLUDE=/opt/local/include -sBZIP2_LIBPATH=/opt/local/lib
 -sEXPAT_INCLUDE=/opt/local/include -sEXPAT_LIBPATH=/opt/local/lib
 -sZLIB_INCLUDE=/opt/local/include -sZLIB_LIBPATH=/opt/local/lib
 -sICU_PATH=/opt/local variant=release threading=single,multi -j8
 architecture=x86 address-model=64 link=shared
 :info:build Exit code: 1
 :error:build org.macports.build for port boost returned: command execution
 :debug:build Error code: CHILDSTATUS 32523 1
 :debug:build Backtrace: command execution failed
     while executing
 "system -nice 0 $fullcmdstring"
     ("eval" body line 1)
     invoked from within
 "eval system $notty $nice \$fullcmdstring"
     invoked from within
 "command_exec build"
     (procedure "portbuild::build_main" line 8)
     invoked from within
 "portbuild::build_main org.macports.build"
     ("eval" body line 1)
     invoked from within
 "eval $procedure $targetname"
 :info:build Warning: targets not executed for boost: org.macports.activate
 org.macports.build org.macports.destroot org.macports.install
 :notice:build Please see the log file for port boost for details:

 I saw online that it's not the first time this happens and that is not
 platform dependant. Tried some fixes with different build variants to no
 Any suggestions?

Ticket URL: <https://svn.boost.org/trac/boost/ticket/12628>
Boost C++ Libraries <http://www.boost.org/>
Boost provides free peer-reviewed portable C++ source libraries.

This archive was generated by hypermail 2.1.7 : 2017-02-16 18:50:20 UTC