Subject: [Boost-bugs] [Boost C++ Libraries] #13588: rename lock_sharable and its methods(and mutex methods) in order of concept of std::lock_shared
From: Boost C++ Libraries (noreply_at_[hidden])
Date: 2018-06-07 08:54:52
#13588: rename lock_sharable and its methods(and mutex methods) in order of concept
of std::lock_shared
---------------------------------------+---------------------------
Reporter: fsmoke@⦠| Owner: Ion Gaztañaga
Type: Tasks | Status: new
Milestone: To Be Determined | Component: interprocess
Version: Boost 1.67.0 | Severity: Cosmetic
Keywords: lock_sharable lock_shared |
---------------------------------------+---------------------------
To make compatible with std locks, interprocess shared mutexes and locks
classes( and they methods) must be renamed according std SharedMutex
concept. see http://en.cppreference.com/w/cpp/concept/SharedMutex.
Example:
boost::interprocess::file_lock::lock_sharable to
boost::interprocess::file_lock::lock_shared
boost::interprocess::file_lock::unlock_sharable to
boost::interprocess::file_lock::unlock_shared
boost::interprocess::file_lock::try_lock_sharable to
boost::interprocess::file_lock::try_lock_shared
boost::interprocess::sharable_lock to boost::interprocess::shared_lock
boost::interprocess::sharable_lock::owns to
boost::interprocess::shared_lock::owns_lock
and so on...
-- Ticket URL: <https://svn.boost.org/trac10/ticket/13588> Boost C++ Libraries <http://www.boost.org/> Boost provides free peer-reviewed portable C++ source libraries.
This archive was generated by hypermail 2.1.7 : 2018-06-07 08:59:12 UTC