Boost logo

Boost-Build :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2001-11-26 09:58:08

Hi Sanket,

If you are building Boost.Jam, you can keep it from trying to run yacc by
setting YACC to "" in your environment. This might be tricky (i.e., you
might need to escape the quotes). On my Win32 system:

make YACC=\"\"

I'm not sure why jam might be dumping core, though.

You might be able to give me enough information to help me help you, though:
why not try running jam with -d+5 and sending me the output of that?

If you build jam with CCFLAGS and LINKFLAGS set appropriately for debug
symbols you could send me a stack backtrace, which would be /really/


P.S. We are starting to post pre-built Jam executables at boost. Once we
figure out how to build Jam for your system, would you consider contributing
an executable?

----- Original Message -----
From: "Khidkikar, Sanket" <skhidkikar_at_[hidden]>
To: <jamming_at_[hidden]>
Sent: Monday, November 26, 2001 9:26 AM
Subject: [jamming] bootstrapping woes

> Hi,
> I have problems bootstrapping jam on my QNX 6 system (with no Yacc
> installed)
> Here is the story:
> -I run make
> -When I get to the point where the jamgram.y is to be parsed to create
> jamgram.c and jamgram.h (I already have these when I untar the sources)
> -Complains that yacc is not found..removes the jamgram.c and jamgram.h
> -Compalins that there is not jamgram.c (and .h) to create jamgram.o
> ....skipping
> -Cannot make the archive since jamgram.o is missing
> -bootstrap is unsuccessful.
> I tried to bypass this problem by tinkering make1.c
> That allowed me to make the jam binary. But then ,when I try to use it to
> build boost libraries I get "memory fault (core dumped) "
> Please help!!!
> Sanket Khidkikar
> _______________________________________________
> jamming mailing list - jamming_at_[hidden]


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at