From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-04-06 09:00:53
----- Original Message -----
From: "Rene Rivera" <grafik666_at_[hidden]>
> >Agreed, unless one load routine calls the other. There's nothing at
> >wrong with re-using the name "load". I confess to not having analyzed
> >Vladimir's "load" code at all. Can someone summarize what it's doing
> >that's different from modules.load?
> Vladimirs code also calls modules.load, but because it doesn't have to
> dictate the tag used to indicate that the jamfile was loaded it
> changes to modules.load. In fact I just realized this is a moot point,
> keep forgetting this. If we have one module per Jamfile, the changes
> did to modules.load are not needed! Yeay :)
> >> So that boils it down to needing another module that
> >> does the file load management. Would a "file" module be apporpriate
> >> this.
> >It depends whether we need it.
> Given what I just said above, I guess we don't need it.
So, given all that, how would you (and Vladimir) like to resolve the
overlap between your work?
One possibility might be for you to pick up the work he's done, and my
commentary, and finalize it. I get the impression that Vladimir has his
hands full with the testing system at the moment.
Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk