Boost logo

Boost-Build :

From: Rene Rivera (grafik666_at_[hidden])
Date: 2002-04-09 21:14:25


On 2002-04-09 at 08:11 PM, david.abrahams_at_[hidden] (David Abrahams) wrote:

>
>----- Original Message -----
>From: "Rene Rivera" <grafik666_at_[hidden]>
>
>> >Actually we don't: they could be named the same as the rules, FWIW.
>> >Anyway, the convention that Rene and I have settled on (I think) is
>that
>> >names with dots in them are intended (module) globals, so
>> >
>> >rule location ( )
>> >{
>> > return $(.location) ;
>> >}
>>
>> I remember that. But I don't think we entirely settled it for
>> psuedo-function vars.
>>
>> I know we leaned towards xxx.yyy, but there is currently one use which
>> doesn't seem to fit that. For the name of the module of Jamfiles
>
>Within the module itself, I am willing to use __name__ which is what
>modules.jam does. But that's not a pseudo-function. Are you talking
>about a variable in some other scope?
>
>>, and
>> project-root, where we need to decorate with a path using the xx.yyy
>style
>> is ugly :-\
>
>Sorry, I'm lost; could you be more explicit?
>
>> Vladimir is currently using xxx_at_path, and I've tried both that
>> and xxx<path>. Opinions?
>
>Is xxx_at_path actually a variable name? We've been using that syntax to
>denote project and target ids...

Oops not explicit enough... In loading Jamfiles and project-roots we
generate unique module names from Jamfile/project-root and the path of the
directory. In project.jam Vladimir is generating those names and using them
to equate to something like:

module Jamfile@/some/dir { ... }

While I've also done this, in build-system.jam, and a new file I have
project.root.jam:

module project-root</some/dir> { ... }

They aren't variables, but it's one place where we haven't thought about for
naming. So I'm asking :-)

Now normally we would use the above through some variable like:

module $(module-name) { ... }

The ugly part comes in when we might do this:

Jamfile</some/dir>.var = value ;
or
Jamfile@/some/dir.var = value ;
or
Jamfile<$(path)>.var = value ;
or
Jamfile@$(path).var = value ;

Is there a better way?

-- grafik - Don't Assume Anything
-- rrivera_at_[hidden] - grafik_at_[hidden]
-- 102708583_at_icq - Grafik666_at_AIM - Grafik_at_[hidden]

 


Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk