From: Vladimir Prus (ghost_at_[hidden])
Date: 2002-07-05 08:30:49
It was agreed that "subproject" is a better name than the current
"subinclude", but now I realize that semantic of "subproject" is not clear.
(I'm actually just trying to document existing functionality, and this might
discover some more problems)
The parent for each project is now found automatically, using crawl-up. So,
what should "subproject" do:
1. Just load the specified jamfile, so that it could declare some
proejct-ids. In this case, the "subproject" name is completely wrong -- it
does not affect project relationship.
2. Cause the specified project to be build whenever current project is build.
The latter option is better for me... and it is the current behaviour
Would we need a separate functionality for the first option?
Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk