Boost logo

Boost-Build :

From: Rene Rivera (grafik666_at_[hidden])
Date: 2002-11-06 00:46:21

[2002-11-05] David Abrahams wrote:

>Rene Rivera <grafik666_at_[hidden]> writes:
>> OK... here's my try at it on RH73... Sorry about the length not sure how
>> much of it is pertinent...
>It looks a bit to me as though you're not using the sane-testing
>branch of tools/build/testing.jam...

I'm sure I have the "sane-testing" file -- Not that I haven't done that
mistake before. :-)

>> [grafik_at_kludge v1-testing]$ bjam-3.1.3
>> ...found 89 targets...
>> ...updating 75 targets...
>> MkDir1 bin
>> MkDir1 bin/link-no.test
>> MkDir1 bin/link-no.test/gcc
>> MkDir1 bin/link-no.test/gcc/debug
>> MkDir1 bin/link-no.test/gcc/debug/runtime-link-dynamic
>> gcc-C++-action bin/link-no.test/gcc/debug/runtime-link-dynamic/a.o
>> gcc-Link-action bin/link-no.test/gcc/debug/runtime-link-dynamic/link-no
>> /usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../crt1.o: In function
>> `_start':
>> /usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../crt1.o(.text+0x18):
>> undefined reference to `main'
>> collect2: ld returned 1 exit status
>> Chmod1 bin/link-no.test/gcc/debug/runtime-link-dynamic/link-no
>> chmod: getting attributes of
>> `bin/link-no.test/gcc/debug/runtime-link-dynamic/link-no': No such file
>> directory
>Hmm, maybe Chmod is interfering with the test slightly on Linux...
>Anyway, when I do it on Linux, I get:
>bjam link-no.test
>....found 12 targets...
>....updating 9 targets...
>MkDir1 bin
>MkDir1 bin/link-no.test
>MkDir1 bin/link-no.test/gcc
>MkDir1 bin/link-no.test/gcc/debug
>MkDir1 bin/link-no.test/gcc/debug/runtime-link-dynamic
>gcc-C++-action bin/link-no.test/gcc/debug/runtime-link-dynamic/a.o
>gcc-Link-action bin/link-no.test/gcc/debug/runtime-link-dynamic/link-no
>/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../crt1.o: In function
undefined reference
>to `main'
>collect2: ld returned 1 exit status
>Chmod1 bin/link-no.test/gcc/debug/runtime-link-dynamic/link-no
>chmod: getting attributes of
>No such file or directory
>**passed** bin/link-no.test/gcc/debug/runtime-link-dynamic/link-no.test
>....updated 9 targets...
>So, while the Chmod is unsightly, it doesn't change the result.

Well there is something that I did that does change the result... I ran
"bjam-3.1.3" in the directory, note: no arguments. But if I run "bjam-3.1.3
link-no.test" I get the results you also get in Linux... STRANGE! So it does
look like, as you point out, that chmod is corrupting the result.

>I wonder if it's acting differently on Cygwin?

I guess you should try the bare "bjam" in cygwin for comparison.

-- grafik - Don't Assume Anything
-- rrivera_at_[hidden] - grafik_at_[hidden]
-- 102708583_at_icq - Grafik666_at_AIM - Grafik_at_[hidden]


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at