Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2003-01-29 01:40:09

Felix E. Klee wrote:
>>>>>Yes, it works now. However, I had to change qt-mt into qt in new/qt.jam
>>>>>since I didn't try to compile the multi threaded QT library for Kylix
>>>>>yet. Shouldn't qt be the default and only be changed to qt-mt when
>>>>><threading> is set to multi?
>>>>You've right! Care to try fixing that? The add-properties rule in qt.jam
>>>>is the key: just compute the library name depending on whether
>>>><theading>multi is in properties.
>>>OK, I'll try it, but probably not today; tomorrow evening is more likely.
>>OK. Good luck.
> Hm, I had a look at it last weekend but couldn't figure out how to make it
> work. I just don't know enough about the boost internals but I guess it is
> trivial for you to solve that problem.

OK. Did it. Now if you run


then "qt" is linked and if you run

bjam threading=multi

then "qt-mt" is used instead.

BTW, seems like it was impossible in the last version --- sorry about that.
You might want to take a look at qt.add-properties to see how this is done now.

> Something else: Today I did a fresh install from the CVS and tried running
> bjam in examples-v2/qt but I got the following error messages:
> /home/felix/projects/jo/src/boost-cvs/boost/tools/build/examples-v2/../new/
> feature.jam:777: in
> *** argument error
> * rule qt.qt.add-properties ( property )
> * called with: ( <uses>qt : <os>LINUX <toolset>gcc <stdlib>native
> <link>shared <link-runtime>shared <optimization>off <threading>single
> <rtti>on <debug-symbols>on <hardcode-dll-paths>false <variant>debug <uses>qt
> )
> * extra argument <os>LINUX

Yea. As I've already told to Jurgen, the problem is that examples are not part
of regression testing, so I've broke qt and did not notice. All should work now.

- Volodya


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at