From: David Abrahams (gclbb-jamboost_at_[hidden])
Date: 2003-05-13 06:47:59
Vladimir Prus <ghost_at_[hidden]> writes:
>> - Throughout these three modules and BBv2 in general there is much
>> inconsistency in terminology and naming. The Dynamic Type Checking
>> proposal above will allow us to write clearer code. Some
>> refactoring will re-group functions in a more meaningful way and
>> re-name them. For example, to convert a property-list to a
>> property-path you call "property.as-path", but to do the opposite,
>> you call "feature.split"; these functions should be in the same
>> module and named in a way that expresses their complementary nature.
> They are not complimentaty!
> [ feature.split [ property.as-path $(p) ] ] != $(p)
> "as-path" produces as compact representation of property set as possible. For
> example, if you have "debug" and "<optimization>off" in property set, then
> only "debug" will show up in "path", because it already contains the second
> property. This means that if you decide to rename 'as-path' you must be
> carefull about the name.
Good point; I should have known that since I wrote property.as-path!
-- Dave Abrahams Boost Consulting www.boost-consulting.com
Boost-Build list run by bdawes at acm.org, david.abrahams at rcn.com, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk