Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2003-07-10 00:07:51


> Ok, here is the test case. It has references to boost_1_30_0 and
> boost-build which you will need to adjust according to your setup.
> Basically it refuses to update C++ targets whenever -a switch is
> present. Even if all binaries removed it just says found that many
> targets, updated this many, without really updating anything. Running
> bjam without -a switch really updates all of them.

I've tried your testcase and... could not reproduce the problem. When I run

bjam -a

from the root, and from the "test" directory, I get:

bash-2.05b$ bjam -a
...found 153 targets...
...updating 2 targets...
gcc.compile.c++ test/bin/gcc/debug/integrator_test.o test/bin/gcc/debug/integrator_test
...updated 2 targets...

I'm almost at lost. If it crashed, you'll see the message box to that effect.
If it did not crashed, it should have produces "...updated XXX targets....."
message. Hmm... maybe you could update bjam from CVS and try again?
BTW, did you use "bjam -a" command line, or there was something else?

- Volodya


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at