Boost logo

Boost-Build :

From: Pedro Ferreira (pedro.ferreira_at_[hidden])
Date: 2003-10-13 07:13:23

Hi Volodya,

> > I'm using Boost.Build V2 (Milestone 7) Boost.Jam 03.01.07.
> > Somehow, the command-line setting doesn't get through - I'll investigate
> > that as soon as I have some spare time. In the meantime, I'd be grateful
> > someone can give me an idea of why this happens...
> I think this might be because command line and environmental variables are
> imported into global module in V2, and when executing actions those
> are not visible.

I thought it could be that.

> Alas, I'm not likely to look into this for a couple of days.
> If you're interested in trying a quick workaround, add
> JAMSHELL on $(targets) = [ modules.peek : JAMSHELL ] ;
> right to the top of 'set-target-variables' rule in "new/toolset.jam". This
> might help.

Apparently it doesn't. I even tried to print out the value of Jamshell
(shell->string) in execnt.c and it is always empty.

FWIW, I think I solved the problem that was causing "piecemeal together" not
to behave as expected in action Clean:
I had changed execnt.c to return 16383 for the maximum line size but the
correct value for XP is 8191. It seems - and it makes sense to me - that
this was confusing jam.

The current status is:

- clean is ok.
- compilation fails if the dependency chain is too long. I have not yet
tried the latest version (which, as you said, reduces the number of
includes) but, eventually, it will fail too with a sufficiently large number
of dependencies. Anyway, the new version should work for me.

Thanks again to Mark and Volodya for your help,



Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at