Boost logo

Boost-Build :

From: epr0nk (epronk_at_[hidden])
Date: 2004-01-06 18:24:13


I tried building the example in build/v2/example/libraries.
The normal build works fine. I got quite impressed by the fact that
the lib is rebuild (if changed) when bjam is run in the app
directory. (yes, i'm new with bjam)

BUT, when I try to link static I get:

$ bjam link=static
...found 22 targets...
...updating 14 targets...
MkDir1 app/bin
MkDir1 app/bin/msvc-6
MkDir1 app/bin/msvc-6/debug
MkDir1 app/bin/msvc-6/debug/link-static
msvc.compile.c++ app/bin/msvc-6/debug/link-static/app.obj
MkDir1 lib1/bin
MkDir1 lib1/bin/msvc-6
MkDir1 lib1/bin/msvc-6/debug
MkDir1 lib1/bin/msvc-6/debug/link-static
msvc.compile.c++ lib1/bin/msvc-6/debug/link-static/lib1.obj
warning: using independent target <plib1/bin/msvc-6/debug/link-
msvc.archive lib1/bin/msvc-6/debug/link-static/lib1.lib

if test -f "$_bbv2_out_" ; then
static\lib1.lib" _bbv2_existing_="lib1\bin\msvc-6\debug\link-
cmd /S /C call "c:\program files\microsoft visual studio\vc98
\bin/vcvars32.bat" > nul "&&" link /lib /NOLOGO "/out:lib1
\bin\msvc-6\debug\link-static\lib1.lib" "/out:lib1\bin\msvc-6
\debug\link-static\lib1.rsp" $_bbv2_existing_ @"lib1\bin\msvc-6

...failed msvc.archive lib1/bin/msvc-6/debug/link-static/lib1.lib
...removing lib1/bin/msvc-6/debug/link-static/lib1.rsp
...skipped <papp/bin/msvc-6/debug/link-static>app.exe for lack of
...failed updating 1 target...
...skipped 1 target...
...updated 12 targets...

I tried it with both msvc-6 and msvc-7.1 (from both bash and cmd)
My bjam is build as Boost.Jam Version 3.1.9. OS=CYGWIN.
I also noticed # include is not found by the dependency scan.

Eddy Pronk


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at