Boost logo

Boost-Build :

From: Samuel Krempp (krempp_at_[hidden])
Date: 2004-01-23 07:19:09

le Friday 23 January 2004 12:37, ghost_at_[hidden] écrivit :
>> Then I tried adding at the head of my Jamfile :
>> import modules ;
>> local MYVARNAME = [ modules.peek : myvarname ] ;
>> and I got
>> Jamfile:7: in modules.load
>> rule import modules ; unknown in module Jamfile</home/sam/progs/simg>.
> I'm at lost. When I add:
> import modules ;
> home = [ modules.peek : HOME ] ;
> ECHO "My home is " $(home) ;
> it works. Maybe, you've got some syntax error before? Could you send me a
> test case?

I'm pretty sure it was a stray "no-break space" iso-8859-1 character 0xA0
invisibly driving me crazy..
I got much more logical results once I spotted the issue and removed all
0xA0 characters from the code parts I had copy-pasted ! (see my other post
about valid char-set).

That's what makes this issue problematic : it is bound to hit new users who
use copy-paste (well, at least french users who copy-paste from Boost.Build
gmane copy using knode), and they're the ones who'll have the hardest time
tracking it down.

It took me several hours before I spotted the 0xA0 chars. I first tried
every possible modification of my jam files..


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at