Boost logo

Boost-Build :

From: Zbynek Winkler (zwin_at_[hidden])
Date: 2004-04-05 06:49:49

Vladimir Prus wrote:

>>The algorithm was said to handle <toolset>msvc-6.0 instead of
>><toolset-msvc:version>6.0 so I tried
>It turns out that this is not yet supported for alternative selection. I'm
>thinking what can be done.
I does not really have to be supported. It is just good to say so ;-)

>>lib cppunit : : <name>cppunitd60 <variant>debug <threading>multi
>><toolset>msvc-6.0 <search>d:/software/cppunit-1.8.0/lib ;
>>but that did not work. For some (to me unknown) reason bjam tried to
>>link against cppunit71.lib so I've got bunch of unresolved referencies.
>>I use msvc-6.0 as my default toolset so I tried compiling with msvc-7.1
>>by issueing 'bjam toolset=msvc-7.1' and this is what I've got:
>>d:/software/boost-build-cvs/v2/build\feature.jam:680: in
>>expand-composites from module feature
>>error: explicitly-specified values of non-free feature
>><toolset-msvc:version> conflict
>>existing values: 7.1 6.0
>Yes, this reproduces for me as well.
The latest patch to targets.jam didn't fix this. Was it supposed to?

>>I give up.
>I think the fix I've comitted should allows you to still use
><toolset-msvc:version>XXX as condition. Meanwhile, I'll look about fixing
>other cases, though as usual, this might take some time.
Well, I am not sure how to test this. Currently I have this:

common = <threading>multi ;
msvc = $(common) <search>d:/software/cppunit-1.8.0/lib ;
msvc6 = $(msvc) <toolset-msvc:version>6.0 ;
msvc71 = $(msvc) <toolset-msvc:version>7.1 ;
gcc = $(common) <toolset>gcc <search>c:/msys/1.0/local/lib ;

lib cppunit : : <name>cppunit60 <variant>release $(msvc6) ;
lib cppunit : : <name>cppunitd60 <variant>debug $(msvc6) ;

lib cppunit : : <name>cppunit71 <variant>release $(msvc71) ;
lib cppunit : : <name>cppunitd71 <variant>debug $(msvc71) ;

lib cppunit : : <name>cppunit <variant>release $(gcc) ;
lib cppunit : : <name>cppunitd <variant>debug $(gcc) ;

This is (should be?) supported, right? Well, when I do 'bjam
toolset=msvc-7.1" I get the error mentioned above. Using msvc-6.0 or gcc
as the toolset works fine.


Faculty of Mathematics and Physics, Charles University, Prague, Czech Republic

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at