Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2004-05-12 02:18:46

Michael Stevens wrote:
> On Tuesday 11 May 2004 22:38, Rene Rivera wrote:
> > Michael Stevens wrote:
> > > It is a little more complete. I call it "intellinux.jam" which I find
> > > visually simpler when specifying properties. Does anyone have any
> > > strong preferences for naming?
> >
> > "icc-linux", or "intel-linux" :-)
> I'm not sure if using '-' is not confusing!

I'm not sure, either. More specifically, I'm not sure we'll handle
intel-linux-8.0 correctly. The dash would make sense of "linux" were just a
subvariant of <toolset>intel, but since intel on linux and windows has
different command line interface, I'm not sure having one toolset with two
subvariants makes sense.

As for icclinux vs. intellinux -- I think I'd prefer the first, but it's not
very important, IMO.

- Volodya


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at