Boost logo

Boost-Build :

From: asterkin2003 (asterkin_at_[hidden])
Date: 2004-05-13 01:22:17

I recently tried to build the complete boost 1_31_0 with regexp
patch, VC7.1 STLPort 4.6.2 and Python 2.3. After some experimentation
the following command line seemed to be working:

bjam "-STOOLS=vc7.1-stlport" "-sBUILD=release debug <native-
wchar_t>on <stlport-iostreams>on" --with-pydebug install


1. If I do not specify <native-wchar_t>on the regexp dll link will
fail. I did not experience such a problem with STLPort 4.6.1 Does it
mean that the default compilation of STLPort has changed? Any
potential problems with this switch?

2. I cannot find the boost_python dlls properly named (with y suffix)
despite the --with-pydebug switch. What's wrong with it?

3. At the end of the build process and before copy of header files
starts I get a bunch of error messages like "... filed HardLink
C:\Boost\lib\boost_thread_vc71-mt-p.lib..." and "Cannot Find
C:\Boost\lib\boost_thread-vc71-mt-p.lib" What does it mean?

4. I'm completely puzzeled with how could I use the Boost.Build for
developing my own software with pre-compiled boost libraries. I tried
to play with the <lib> switch but without any success. Could I get
some sample Jamfile to be educated from?

Any help will be highly appreciated.



Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at