Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2004-07-06 06:22:04

Hi Philipp,

> I am using the stuff ripped from boost_1_31_0.tar.gz, the v2 stuff.

Yes, this explains things.

> I tried to access CVS but there seems to be a problem:
> cvs -d:pserver:anonymous_at_cvs.sourceforge.n et:/cvsroot/boost co boost
> can't create temporary directory /tmp/cvs-serv24024
> Permission denied

Strange, this command works fine with me (at least when I remove the space
between "n" and "et", but I guess that's just copy-paste error)

You probably can try later.

> There is no snapshot download available, isn't it?

Why not, try

There's also mirror at

cvs -d:pserver:anonymous_at_[hidden]:/boost co boost

>> Unfortunately, you also add some file to your project depending
>> on presense of the library, and there's no builtin way to do this.
>> The way you do it is perfectly OK, though if you are not scared
>> of being the first one to try a new idea I've just got, you can try:
> I am not scared at all. Your 'new' solution even looks elegant to me.
> However, my version of Boost.Build v2 does not recognise the <source>.
> Is this only in CVS?

Yes. We used to have <library>, which could add source but worked only
worked for library targets. So <source> was introduced, which works
everywhere (and <library> is just a synonym for <source> now).

- Volodya


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at