Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2004-09-29 02:35:22

Hi Zbynek,
> Hello! I think that the following worked also for msvc:
> lib test : : <name>test ;

I could not confirm this. When I do:

lib m : : <name>m ;
exe a : a.cpp m ;

The command include:

echo "m.lib" >> "bin/msvc-7.1/debug/a.rsp"

which looks right. BTW, in CVS version,

lib m ;

would also work.

> However, it seems that now I need to say <name>test.lib in order to link
> to the library. So I tried to workaround this problem by
> lib test : : <name>test <toolset>gcc ;
> lib test : : <name>test.lib <toolset>msvc ;
> which I think also used to work, but it does not now "because no
> best-matching alternative could be found" :-(. Why is that?

I can't confirm this either. With those line, "bjam -n msvc gcc" works just

Are you sure you're using the unmodified CVS version, such as the snapshot

Anything special in your user-config.jam?

- Volodya


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at