Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2004-12-29 06:52:23

On Wednesday 29 December 2004 03:37, Eric Niebler wrote:
> David Abrahams wrote:
> >>>Strange. My build fails too, but very differently.
> My build fails too, but with yet a different error. For instance, trying
> to build the date_time docs yields:
> C:\boost\cvs\boost\libs\date_time\xmldoc>bjam --v2 -a
> C:/boost/cvs/boost/tools/build/v2/build\virtual-target.jam:507: in path
> *** argument error
> * rule path.root ( path root )
> * called with: ( ../../../bin.v2/libs/date_time/xmldoc )
> * missing argument root

Hmm... I've tried from ~boost_root/doc and it worked. Turns out that building
the same directory where doxygen rule is invoked is broken.

I've committed a fix for this. And I've also done which should have being done
a long time ago -- I've committed a test for boostbook functionality
(including doxygen). Hopefully this will prevent breakage in future.

- Volodya


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at