Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2005-04-11 09:40:03

Hi Peter,

> I build a small library using Boost.Build v2 (as found in CVS-HEAD), and
> until recently that worked just fine. Out of the sudden I get compiler
> errors when building with icc version 8.0, though:
> /path/to/bindir/intel-linux-8.0/debug/threading-multi/
> /usr/bin/ld: -static and -shared may not be used together
> "icpc" -o
> The compiler is configured in a global /etc/site-config.jam file as
> follows:
> using intel-linux
> : 8.0
> :
> : <cxxflags>"-D__interface=tmpinterface" ;
> The define is required to work around a problem with glibc headers; I doubt
> it causes this problem.
> I don't see where the -static flag comes from. The command shown above (as
> echoed by bjam) doesn't seem to include it.

Strange. I've built some .so today with CVS HEAD state (namely, Boost.Python
library and some extension), and it worked.

> Any ideas or pointers what is causing this?

Maybe, somebody else knows :-(
Do you get this on "example/library" project?

> P. S.: I also got problems with the statement
> using python : 2.3 : /usr ;
> in my /etc/site-config.jam out of the sudden. bjam spouted lots of warnings
> when reading the site config and I had to remove the line altogether to
> make it happy again. No idea why. Maybe that's related?

This is supposed to work! What warnings to you get?

- Volodya

Vladimir Prus
Boost.Build V2:

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at