Boost logo

Boost-Build :

From: David Abrahams (dave_at_[hidden])
Date: 2005-04-28 10:44:22

Brian Ravnsgaard Riis <brian_at_[hidden]> writes:

> Hello list.
> I've been having trouble using mingw with BBv2 for some time, due to a
> failure to invoke action gcc.archive. I got our old friend "spawn: No
> such file or directory", which tells next to nothing about what really
> went wrong.
> Investigation showed that since gcc.archive is a two-line action (remove
> then archive) it choked on that somehow. Commenting out either or both
> lines made no difference, i.e. still no successful run. *Deleting* one
> of the lines, however, solved the problem, except, of course, that both
> lines are there for a reason. The problem turned out to be located
> somewhere else.
> In the top of gcc.jam a little trick is present to circumvent trouble
> with command line length on NT. It sets the JAMSHELL variable to '%'.
> This was why it choked.

It shouldn't have. '%' is only supposed to take effect for
single-line commands.

> I have replaced this with
> "JAMSHELL = cmd.exe /C %"
> Now everything works.

That will break when you run up against the command-line length
limitation. You may as well leave off setting JAMSHELL altogether in
that case, because it amounts to roughly the same thing.

Dave Abrahams
Boost Consulting

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at