Boost logo

Boost-Build :

From: DJB (usrlocalinfo_at_[hidden])
Date: 2005-04-29 03:40:46

Vladimir Prus wrote:
> On Friday 29 April 2005 11:11, DJB wrote:
>>For some strange reason I haven't been able to figure out for 5+
>>hours...the testdll.dll source code never gets compiled even after
>>--clean. Only the libraries get recompiled if I use --clean.
>>In fact, the bin directory doesn't even get created anymore after I
>>deleted it.
>>I don't have this problem with any other dll project. Only this one is
>>causing problems.
>>What kind of mistake or typo would cause this weird symptom? I don't
>>get any error messages (bjam just pretends as if all the code inside the
>>testdll project directory is already compiled up-to-date). I tried
>>--clean, manual delete of bin/*, touch'ing *.cpp, etc.
> Nothing's suspicious in your code. Can you try:
> bjam -d12 ....
> bjam --debug-generators ....
> bjam --debug-building ...
> and send me the output from all three invocations?
> - Volodya

I tried one more thing, based on the smaller debug output.

It looks like the problem can be 'fixed' by commenting out one line in
the following snippet:


I think the problem is caused by a bug that is causing the testdll
project directory to be treated as if it was specified by <search> which
is strange since they aren't even on the same drive. What I'm saying
is probably completely wrong, I'm going to bed before I continue saying
stupid things...thanks again for all the help Vlad!

# project inherits reqs from parent
project testdll
: requirements
##BAD## <search>"C:/src/wxWidgets-2.6.0/lib/vc_lib"


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at