Boost logo

Boost-Build :

From: motor_hiker (jpfritz_at_[hidden])
Date: 2005-06-21 00:29:19


My problem is probably due to my Linux/unix inexperience (I haven't
really used it in 5+ years), but I seem to be stuck. I'm trying to run
tutorial programs in the Boost.Thread lib. I ran
bjam -sTOOLS=gcc install
and that seemed to be fine (libs created in /usr/local/lib). I then
went down to the tutorial dir under the thread lib and ran
bjam -sTOOLS=gcc.
That created executables in
<boost path>/boost_1_32_0/bin/boost/libs/thread/tutorial/<tutorial
I then tried to run them from their respective dirs, but I get:
error while loading shared libraries: cannot open shared object
file: No such file or directory

The library is in /usr/local/lib and that dir is in my path. I get the
same thing if I copy the executable to that dir, so I don't think it's
the path. That lib is also readable and executable by everyone. Am I
neglecting something really stupid here?



Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at