Boost logo

Boost-Build :

From: Joaquín Mª López Muñoz (joaquin_at_[hidden])
Date: 2005-08-30 10:02:30

* Cygwin 1.5.7
* GCC 3.2

I've got a very simple (testing-based) Jamfile that works fine, and
I'd like to run one of the tests with multithreading options:

bjam "-sTOOLS=GCC" "-sBUILD=<threading>multi" test_basic

This invocation succeeds, but I can see in my code that
BOOST_HAS_THREADS is *not* defined. I've tried also

bjam "-sTOOLS=GCC" "-sBUILD=<threading>multi <define>BOOST_HAS_THREADS"

with a similar effect: BOOST_HAS_THREADS is later undef'd, I
guess by some Boost.Config header.

My last attempt involved expicitly plugging the <threading>multi
in the test rule itself inside the Jamfile, same result.

So, what need I have to do in order to enable multithreading support
under the
aforementioned platform? I guess I'm missing something very obvious, and
kinda stupid :(

Thank you,

Joaquín M López Muñoz
Telefónica, Investigación y Desarrollo


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at