Boost logo

Boost-Build :

From: Markus Schöpflin (markus.schoepflin_at_[hidden])
Date: 2006-02-14 07:26:46

Vladimir Prus wrote:

> On Tuesday 14 February 2006 13:09, Markus Schöpflin wrote:
>> I think I'll try a V2 regression run next. But for this I need a customized
>> toolset. I tried to put the following into a file called
>> 'tru64cxx65-042.jam' living in BOOST_BUILD_PATH.
>> ---%<---
>> using tru64 : :
>> <cflags>"-version V6.5-042"
>> <ldflags>"-version V6.5-042 -use_non_shared_libcxx"
>> ;
>> --->%---
>> But when trying the command ' bjam -a -n --v2 tru64cxx65-042'
> In V2, the name of file has nothing to do with version number you request on
> command line. The above code declared 'tru64' toolset without any version.
> Try
> using tru64 : cxx65_042 :
> <cflags>"-version V6.5-042"
> <ldflags>"-version V6.5-042 -use_non_shared_libcxx"
> ;
> and then
> bjam -a -n --v2 tru64-cxx65_042
> Note that '65' and '042' must be separated by underscore, not dash.

Still no luck. My toolset description looks now like this:

using hp_cxx : hp_cxx_65_042_tru64 :
   <cflags>"-version V6.5-042"
   <ldflags>"-version V6.5-042 -use_non_shared_libcxx"

and lives in BOOST_BUILD_PATH as hp_cxx_65_042_tru64.jam.

But bjam -a -n --v2 hp_cxx_65_042_tru64 still gives an error:

boost-HEAD/libs/test/test> bjam -a -n --v2 hp_cxx_65_042_tru64
Building Boost.Regex with the optional Unicode/ICU support disabled.
Please refer to the Boost.Regex documentation for more information
(and if you don't know what ICU is then you probably don't need it).
notice: could not find main target hp_cxx_65_042_tru64
notice: assuming it's a name of file to create
don't know how to make <e>hp_cxx_65_042_tru64
...found 1 target...
...can't find 1 target...


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at