Boost logo

Boost-Build :

From: Zbynek Winkler (zw-bjam_at_[hidden])
Date: 2006-04-03 09:26:00

Jürgen Hunold wrote:

>It is nearly impossible to decipher something like
>alias dummy
> :
> :
> :
> :
> <define>SOMETHING
> ;
>I'd just like to have something more readable then all those colons.
I couldn't agree more.

>My favorite is something like
>lib foo
> : source a.cpp b.cpp c.cpp
> : build <define>BUILD_DEFINE
> : common <include>my_path
> : used <define>MY_DEFINE
> ;
I am not sure about requiring the "source" but in general I like the idea.

+1 from me

I also like "build" before "self" but that probably depends on POV. My
implicit default is "self" and I ask myself "what to do with it" so
having "build" and "use" feels natural. However, I can understand
David's POV with the implicit default being "build" and asking "what am
I going to build today?" responding with "self", "all" etc. The former
just feels more natural.


Faculty of Mathematics and Physics, Charles University, Prague, Czech Republic

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at