Boost logo

Boost-Build :

From: King, Steven R (steven.r.king_at_[hidden])
Date: 2006-04-09 15:19:37

I'm using bbv2 from the 1_33_1 boost package. I'm experimenting with a
simple library and its test program. Compiled and passed tests fine on
Fedora Core 4. When I tried the exact same source tree on my Windows
machine with msvc 7.1, the test program failed to link for lack of the
.lib file. Adding <static> to the test program requirements made it
work. Obviously, I'd like the same Jamfile to work in both
Why would this Jamfile work with Linux gcc, yet fail to link without
<static> in msvc?

Thanks for any guidance.

Here's my Jamfile that worked under gcc but not msvc:

# symbolic name of this code
# and common requirements
project ctllib
    : requirements <include>$(SW_ROOT)/lib

lib ctllib
    : # sources

    : # requirements
    : # default build
    : # usage-requirement

run test/test_qlist.c ctllib
    : # args
    : # input files
    : # requirements
        # <static> needed for MSVC !?!
    : # name
    : # default build
    debug release

Error message in msvc:
LINK : fatal error LNK1181: cannot open input file

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at