Boost logo

Boost-Build :

From: Pedro Lamarão (pedro.lamarao_at_[hidden])
Date: 2006-05-30 20:26:30

In the attached package there is a project copied from the tutorial,
with a simple modification.

I tried, on a simple project, the following trick:

lib network
        [ glob *.cpp ]
        [ lib ws2_32 ]

and it worked: ws2_32.lib was linked in.

But that, for some reason, disturbs the use of alternatives for a
target. Calling bjam in the attached project directory I get:

[pedro_at_localhost test2]$ bjam
/home/pedro/Projetos/boost-build-cvs/build/feature.jam:430: in
validate-value-string from module feature
error: "msvc" is not a known value of feature <toolset>
error: legal values: "gcc"
/home/pedro/Projetos/boost-build-cvs/build/feature.jam:314: in
expand-subfeatures-aux from module feature
/home/pedro/Projetos/boost-build-cvs/build/feature.jam:372: in
expand-subfeatures from module feature
/home/pedro/Projetos/boost-build-cvs/build/feature.jam:738: in
feature.expand from module feature
/home/pedro/Projetos/boost-build-cvs/build/targets.jam:934: in
common-properties2 from module targets
/home/pedro/Projetos/boost-build-cvs/build/targets.jam:907: in
targets.common-properties from module targets
/home/pedro/Projetos/boost-build-cvs/build/targets.jam:1145: in
object(typed-target)@36.generate from module object(typed-target)@36
/home/pedro/Projetos/boost-build-cvs/build/targets.jam:759: in
generate-really from module object(main-target)@42
/home/pedro/Projetos/boost-build-cvs/build/targets.jam:735: in
object(main-target)@42.generate from module object(main-target)@42
/home/pedro/Projetos/boost-build-cvs/build/targets.jam:252: in
object(project-target)@29.generate from module object(project-target)@29
/home/pedro/Projetos/boost-build-cvs/build-system.jam:296: in load from
module build-system
/home/pedro/Projetos/boost-build-cvs/kernel/modules.jam:261: in import
from module modules
/home/pedro/Projetos/boost-build-cvs/kernel/bootstrap.jam:132: in
boost-build from module
/home/pedro/Projetos/boost-build-cvs/boost-build.jam:2: in module scope
from module

I get this result with both M11 RC2 and latest CVS.

Is that "embedded" [ lib ] correct?
Am I missing something?

I do see workarounds to the same effect.
It's just that Boost.Build promises so sweet easiness, just to take it
away later...

 Pedro Lamarão

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at