Boost logo

Boost-Build :

From: Vladimir Prus (ghost_at_[hidden])
Date: 2007-08-09 11:23:53

Ray Lambert wrote:

> Ray Lambert wrote:
>> Thanks, that worked very well. It still has to be manually updated but
>> at least now it only needs to be updated in one place (and committed).
>> I had to change the command though to <target-os>windows and to use a
>> full
>> windows path. I guess I'm using a somewhat mixed environment; I'm
>> building with <target-os>windows but using cygwin's gcc (which is the
>> only
>> gcc I have installed). This is the final command that I used (in
>> Jamroot):
>> project
>> : requirements
>> <target-os>windows:<include>d:/cygwin/usr/include/boost-1_33_1
>> <target-os>linux:<library>rt
>> ;
>> (The last requirement is for my linux builds, of course.)
> Hmmm... replying to myself here...
> I *thought* I had tested that last part ("<target-os>linux:<library>rt")
> but it turns out that it doesn't work. I get an error saying it can't
> find "rt" (but "[ lib rt ]" on the "exe" line works fine). I had to use
> this instead (which did work):
> project
> : requirements
> <target-os>windows:<include>d:/cygwin/usr/include/boost-1_33_1
> <target-os>linux:<linkflags>-lrt
> ;
> *Should* "<library>rt" have worked?

No. <library> is a dependency feature and the value of it should
be a name of a target. If you don't declare target named 'rt' in your
Jamfile, then


won't work. You can use:



- Volodya

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at