Boost logo

Boost-Build :

From: Robert Ramey (ramey_at_[hidden])
Date: 2007-08-14 11:07:13

Hmmm - I tried the attached stlport.jam and got the following message

I used bjam --dump_tests .--toolset=msvc-7.1 stdlib=stlport-5.0

Robert Ramey

Building Boost.Regex with the optional Unicode/ICU support disabled.
Please refer to the Boost.Regex documentation for more information
(don't panic: this is a strictly optional feature).
C:/BoostSVN/boost/tools/build/v2/build\feature.jam:432: in
validate-value-string from module feature
error: "stlport-5.0" is not a known value of feature <stdlib>
error: legal values: "native"
C:/BoostSVN/boost/tools/build/v2/build\feature.jam:316: in
expand-subfeatures-aux from module feature
C:/BoostSVN/boost/tools/build/v2/build\feature.jam:374: in
feature.expand-subfeatures from module feature
C:/BoostSVN/boost/tools/build/v2/build\build-request.jam:20: in
apply-to-property-set from module build-request
C:/BoostSVN/boost/tools/build/v2/kernel\modules.jam:66: in
from module build-request
C:/BoostSVN/boost/tools/build/v2/util\sequence.jam:44: in sequence.transform
from module sequence
C:/BoostSVN/boost/tools/build/v2/build\build-request.jam:30: in
build-request.expand-no-defaults from module build-request
C:/BoostSVN/boost/tools/build/v2\build-system.jam:274: in load from module
C:\BoostSVN\boost\tools\build\v2/kernel\modules.jam:261: in import from
module modules
C:\BoostSVN\boost\tools\build\v2/kernel/bootstrap.jam:132: in boost-build
from module
C:\BoostSVN\boost\boost-build.jam:9: in module scope from module

David Deakins wrote:
>> Robert Ramey wrote:
>>> One more thing, The tests which fail to link do so with the message:
>>> LINK : fatal error LNK1181: cannot open input file
>>> 'stlportstld.5.lib'
>>> Robert Ramey wrote:
>>>> Robert Ramey wrote:
>>>>> However, I'm quite surprised to see the bin.v2 directory look like
>>>>> the following:
>>>>> bin.v2/libs/serialization/test/test_const_fail1.test/msvc-7.1/debug/stlport-5.0/stlport-5.0/threading-multi
>>>>> whoops - above should read:
>>>> bin.v2/libs/serialization/test/test_const_fail1.test/msvc-7.1/debug/stdlib-stlport-5.0/stdlib-stlport-5.0/threading-multi>>
>>>> Note that the repetition of stlport-5.0 is not a typo - it appears>
>>>> twice in the path.
>> Hi Robert,
>> I ran into both of these issues with BBv2 stlport.jam file as well
>> as a
>> couple others. I spent some time debugging this a while back
>> (, but it looks
>> like I was negligent in submitting a full-blown path. Attached is
>> the
>> version of the tools/build/v2/tools/stlport.jam that I have been
>> using,
>> along with a patch against the current rev of the file. I'm not
>> sure if
>> I solved these issues in the ideal manner, but it seems to work for
>> my
>> installation.
>> -Dave

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at