Boost logo

Boost-Build :

From: Denis Tkachov (dtkachov_at_[hidden])
Date: 2007-10-08 09:07:27

platform - Mac OS (Leopard)
boost: v.1.34

I have build boost with bjam. Bjam put its output to stage/lib folder.
I have specified full path to this folder in xcode project settings -
xcode cannot map the boost serialization library. Than I have
specified library in hand (I all the libraries - debug/release,
multitreaded, etc..) - xcode still fail to map boost libraries.

Same things I have tried with building library from command line using
gcc (g++) compiler.
G++ returns: "ld: in build, can't map file, errno=22"
Sample of command line is:
g++ * -I ~/lib/boost/boost_1_34_1/

BTW - sample listed here do not work for Mac OS X:

according to this sample I have to use such command line:
g++ * -I ~/lib/boost/boost_1_34_1/ -L
~/lib/boost/boost_1_34_1/stage/lib/ -llibboost_serialization-mt.a
in this case g++ out is "ld: library not found for

Omitting specification of suffix and prefix (as mentioned in manual
when set path via "-L" parameter and library via "-l" parameter) also
does not work.

Such command line (omitting "-L" parameter) also does not work :
g++ * -I ~/lib/boost/boost_1_34_1/
ld: in build, can't map file, errno=22

>From above mentioned manual I noticed that boost library files must
contain "gcc" in name. I have found such files in bin.v2 forlder.
For example here:

But linking with this file fails too.

Same project links and woks great under windows with same boost library.
Windows project links with boost serialization library

Please help me with liking boost serialization library under Mac OS X.

Best regards,

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at