Boost logo

Boost-Build :

From: Hicham Mouline (hicham_at_[hidden])
Date: 2007-10-23 14:38:23

The intel compiler (vista64) I have installed generates 64bit only. No
option needs to be passed then.
I ran :
bjam --build-dir="c:\Users\hich\Documents" --toolset=intel-10.0
--with-date_time stage
from Boost root dir.
(all installed with the winstaller from boost consulting)
I get these errors:

...found 488 targets...
...updating 52 targets...
MkDir1 stage
    mkdir "stage"
Access is denied.
...failed MkDir1 stage...
...skipped stage\lib for lack of stage...




At this stage, it tries to run greg_month.obj.rsp, but it doesn't know how
to open it, so it asks me to choose a program.

I don't think it calls the Intel compiler at all. (I don't know if it reads
the environment variables that define the intel compiler path)


-----Original Message-----
From: boost-build-bounces_at_[hidden]
[mailto:boost-build-bounces_at_[hidden]] On Behalf Of Vladimir Prus
Sent: 23 October 2007 16:29
To: boost-build_at_[hidden]
Subject: Re: [Boost-build] intel toolset

Hicham Mouline wrote:

>> It does not seem like intel support in Boost.Build has special provision
>> for 64-bit compilation. Are you aware how it should be activated, on
>> command line?
>> - Volodya
>> _______________________________________________
> aha, so 64bit is not supported by Boost-build?
> what if i run this:
> bjam --build-dir="c:\Users\hich\Documents" --toolset=intel-10.0
> --with-date_time stage
> will it generate 32bit binaries? for intel compiler?
> i guess that will not work with my 64bit-only intel compiler?

I don't know. For msvc, 64-bit mode is activated using address-mode=64.
I don't know how intel works. If it need special command line options,
then it won't work. If there's '64-bit' compiler that generated 64
bit binaries when invoked, then no special support needed.

Can you check with intel docs and get back to me?

- Volodya

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at