Boost logo

Boost-Build :

From: Gennadiy Rozental (rogeeff_at_[hidden])
Date: 2008-01-15 20:24:59

"Vladimir Prus" <ghost_at_[hidden]> wrote in message
> Gennadiy Rozental wrote:
>> I am sure it's something very simple, but I can't figure it out.
>> What I need to to link my unit test with thread library. I looked how
>> other Jamfiles are doing it and tried to reproduce it. It failed. After
>> an
>> hour of jumping with tambourine around my Jamfile, I've tried thread
>> library own example. Same story. Here is an error:
>> bjam --preserve-test-targets -d +2 toolset=msvc-8.0
>> warning: Graph library does not contain optional GraphML reader.
>> note: to enable GraphML support, set EXPAT_INCLUDE and EXPAT_LIBPATH to
>> the note: directories containing the Expat headers and libraries,
>> respectively. warning: skipping optional Message Passing Interface (MPI)
>> library. note: to enable MPI support, add "using mpi ;" to
>> user-config.jam. note: to suppress this message, pass "--without-mpi" to
>> bjam. note: otherwise, you can safely ignore this message.
>> Building Boost.Regex with the optional Unicode/ICU support disabled.
>> Please refer to the Boost.Regex documentation for more information
>> (don't panic: this is a strictly optional feature).
>> ..../boost-trunk/tools/build/v2/build\virtual-target.jam:415: in
>> _adjust-name from module object(file-target)@411
>> error: <tag>@rulename is present but is not the only <tag> feature
>> ..../boost-trunk/tools/build/v2/build\virtual-target.jam:224: in
> .....
>> Please advise,
> Please bring it up with Boost.Thread developers. There's no evidence that
> Boost.Build
> has a bug here.

1. Even if it caused by any of them, it's still a problem in Boost.Build -
no one but you can explain what all that giberish above means. Can you give
us short description in layman terms what is wrong here.

2. BTW, do you see it yourself? Can you reproduce it?

3. To be frank with you I doubt it's boost.thread fault. It worked fine till
I updated boost trunk and I can't see them committing change that would
break like this. I am not sure it's Boost.Build fault either. The most
possible suspect here is myself - something in my
environment/installation/hands etc. But I can't figure it out from the error
message and I exhasted all that I can do by myself.


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at