Boost logo

Boost-Build :

From: Mat Marcus (mat-lists_at_[hidden])
Date: 2008-04-15 18:12:21

On Tue, Apr 15, 2008 at 11:09 AM, Roland Schwarz
<roland.schwarz_at_[hidden]> wrote:
> Mat Marcus wrote:
> > Thanks for pointing that out. In any case, it is not a gcc 4 issue,
> > since it also occurs with the gcc 3.4.x cygwin distribution.
> I today sucessfully tried latest cygwin (i.e. with gcc 3.4.4 and under
> bash) and bjam vom boost/trunk.

That's interesting. As I posted below, it still doesn't build for me.

> > It's
> > possible that there is something wrong with my configuration, but that
> > would surprise me a litlle since things worked fine with 1.34.1. If
> > not, I wonder whether this could be an instance of increased support
> > for mingw gcc in 1.35.0 at the expense of cygwin gcc support?
> Not likely. Can you possibly try with bjam from trunk?

Out of curiosity, could you please tell me whether you are involved in
the maintainance of bjam sources for windows? Here are the results:

mmarcus_at_EULER ~/boost-svn/boost-trunk/tools/jam
$ svn up
U doc/bjam.qbk
U doc/history.qbk
U src/filent.c
U src/execnt.c
U src/modules/property-set.c
U src/make1.c
U src/regexp.c
 U src/boehm_gc/win32_threads.c
 U src/boehm_gc/mallocx.c
 U src/boehm_gc/cord/de_win.ICO
 U src/boehm_gc/typd_mlc.c
 U src/boehm_gc/config.sub
 U src/boehm_gc/misc.c
U src/native.c
U src/builtins.c
U src/lists.c
U src/filesys.c
U src/build.bat
U src/execunix.c
Updated to revision 44444.

mmarcus_at_EULER ~/boost-svn/boost-trunk/tools/jam
$ cd src

mmarcus_at_EULER ~/boost-svn/boost-trunk/tools/jam/src
$ ./
### Using 'gcc' toolset.
rm -rf bootstrap
mkdir bootstrap
gcc -o bootstrap/jam0 command.c compile.c debug.c expand.c glob.c
hash.c hdrmacro.c headers.c jam.c jambase.c jamgram.c lists.c make.c
make1.c newstr.c option.c output.c parse.c pathunix.c pathvms.c
regexp.c rules.c scan.c search.c subst.c timestamp.c variable.c
modules.c strings.c filesys.c builtins.c pwd.c class.c native.c
w32_getreg.c modules/set.c modules/path.c modules/regex.c
modules/property-set.c modules/sequence.c modules/order.c execunix.c
./bootstrap/jam0 -f build.jam --toolset=gcc --toolset-root= clean
assertion "!strcmp( l->string, "c:\\foo\\bar" )" failed: file
"expand.c", line 752

The key may be in what expand.c wants the value of l->string to be
where the assertion is occuring, if not c:\foo\bar . Anyone know?


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at