Boost logo

Boost-Build :

From: Robert Ramey (ramey_at_[hidden])
Date: 2008-05-02 00:45:28

I tried to build the borland test on my own system but discovered I had
removed the 5.64 compiler that I was using to test. I tried to re-install
it from the CD but I got bogged down in something or other and I've been
swamped anyway.

Last I looked, here is what needed to be done:

a) tweak the serialization Jamfiles to fix the code which enforces the
requirement for spirit 1.6x for those compilers which need it. This
includes borland 5.6x and others. This should be easy for someone who
understands bjam. (I don't)

b) I believe that building binary_archive fails with borland. This inhibits
the build of the whole library. I would guess that after a) is addressed,
this would be a small but tricky fix.

After that, I would expect that things work work for borland as well as they
did for 1.33 - which wasn't too bad.

Robert Ramey

siliconman wrote:
> In article <fv23l0$o52$1_at_[hidden]>,
> "Robert Ramey" <ramey_at_[hidden]> wrote:
>> In V2 - I tried to update my Jamfile to handle this but have
>> been unsuccessful. I did ask for help on this a couple of
>> times on the build list - but the response I got suggested
>> what I did should work - so here we are.
>> I would love to get this fixed so I could test this
>> compiler on my own system.
> So what needs done here? As it stands I am unable to do regression
> testing at all. I'm very much willing to put time into this, but I
> need at least a starting point.

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at