Boost logo

Boost-Build :

From: Stjepan Rajko (stipe_at_[hidden])
Date: 2008-05-30 23:44:33


I am trying to use boost build with GCC 4.3 (built using Fink) on OS
X, and running into problems. At first, I was facing issues similar
to those explained here:

I got around that by butchering gcc.jam (removing the lines
introducing the offending options), and eventually got to a point
where I can build a simple executable. However, when the build
process includes a library that is to be linked into the executable, I
get e.g.:

ld: in /Development/boost/bin.v2/libs/signals/build/gcc-4.3/debug/link-static/libboost_signals-gcc43-d-1_35.a,
archive has no table of contents

I tried messing with gcc.jam some more to get it to use libtool
instead of ar for archiving, but with libtool it would still get the
same "archive has no table of contents" problem.

I'm not an expert with respect to building (in the context of or gcc or os x), so my attempts to get this to work are
mostly shots in the dark (and maybe there is something basic was
supposed to do that I am not aware of). If anyone has any suggestions
I'd greatly appreciate it.



Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at