Boost logo

Boost-Build :

From: Daniel James (daniel_james_at_[hidden])
Date: 2008-07-01 06:30:43

2008/7/1 Jurko Gospodnetiæ <jurko.gospodnetic_at_[hidden]>:
> Forgot to mention in my previous post I tried it on Windows XP, not Ubuntu.
> Also, I just tried it some more this morning including trying to fool
> around with the BuildDir options but all paths kepts getting detected
> consistently.

It fails to build on both Ubuntu and OS X. So I assume the problem
might be on all Posix based systems - possibly including Cygwin if
you're windows only. The solution might be just to use 'mkdir -p' on
these platforms, when the '-p' flag is used mkdir doesn't return an
error is the directory already exists

> I did find a bug in doxygen.jam in case you specify an absolute build dir
> and posted a patch for it but that does not seem to be related to your
> problem.
> Changeset link:
> Changeset link:

I don't know if this is related, but now I'm getting new build errors.
Running bjam in 'libs/algorithm/string/doc', I get:

xslt-xsltproc ../../../../bin.v2/libs/algorithm/string/doc/darwin-4.0/debug/autodoc-xml.doxygen
warning: failed to load external entity
unable to parse /Users/daniel/stuff/boost/libs/algorithm/string/doc/index.xml

 "xsltproc" --stringparam doxygen.xml.path
"/Users/daniel/stuff/boost/libs/algorithm/string/doc" --xinclude -o

...failed xslt-xsltproc
...skipped <p../../../../bin.v2/libs/algorithm/string/doc/darwin-4.0/debug>autodoc-xml.boostbook
for lack of <p../../../../bin.v2/libs/algorithm/string/doc/darwin-4.0/debug>autodoc-xml.doxygen...
...skipped <p.>autodoc.xml for lack of
...skipped <p../../../../bin.v2/libs/algorithm/string/doc/darwin-4.0/debug>string_algo.docbook
for lack of <p.>autodoc.xml...
...skipped <phtml>string_algo_HTML.manifest for lack of
...failed updating 1 target...
...skipped 4 targets...

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at