Boost logo

Boost-Build :

Subject: Re: [Boost-build] Fwd: [Boost-testing] problem running nightly tests
From: K. Noel Belcourt (kbelco_at_[hidden])
Date: 2008-11-06 12:40:24


On Nov 6, 2008, at 2:43 AM, Vladimir Prus wrote:

> K. Noel Belcourt wrote:
>> [ forwarded from Boost.testing ]
>> Begin forwarded message:
>>> From: "K. Noel Belcourt" <kbelco_at_[hidden]>
>>> Date: November 5, 2008 2:27:46 PM MST
>>> To: Running Boost regression tests <boost-testing_at_[hidden]>
>>> Subject: [Boost-testing] problem running nightly tests
>>> Reply-To: Running Boost regression tests <boost-
>>> testing_at_[hidden]>
>>> Hi,
>>> One of more daily trunk tests just died with this error message.
>>> /private/tmp/kbelco/boost/tools_bb/build/toolset.jam:461: in
>>> toolset.inherit-rules
>>> IMPORT error: rule "" unknown in module "gcc."
> boost-testing list apparently does not like me, and the message I've
> posted yesterday still did not show up. Here it is:
> K. Noel Belcourt wrote:
>> Hi,
>> One of more daily trunk tests just died with this error message.
>> /private/tmp/kbelco/boost/tools_bb/build/toolset.jam:461: in
>> toolset.inherit-rules
>> IMPORT error: rule "" unknown in module "gcc."
> Should be fixed now. Sorry for breakage.

Just tried again, got the same error (with quite a bit more context
this time). Note that I'm trying to run trunk tests on darwin

### Using 'darwin' toolset.
rm -rf bootstrap
mkdir bootstrap
cc -DNO_VFORK -o bootstrap/jam0 command.c compile.c debug.c expand.c
glob.c hash.c hdrmacro.c headers.c jam.c jambase.c jamgram.c lists.c
make.c make1.c newstr.c option.c output.c parse.c pathunix.c
pathvms.c regexp.c rules.c scan.c search.c subst.c timestamp.c
variable.c modules.c strings.c filesys.c builtins.c pwd.c class.c
native.c w32_getreg.c modules/set.c modules/path.c modules/regex.c
modules/property-set.c modules/sequence.c modules/order.c execunix.c
./bootstrap/jam0 -f build.jam --toolset=darwin --toolset-root= clean
...found 1 target...
...updating 1 target...
...updated 1 target...
./bootstrap/jam0 -f build.jam --toolset=darwin --toolset-root=
...found 47 targets...
...updating 2 targets...
[MKDIR] bin.macosxx86
[COMPILE] bin.macosxx86/bjam
...updated 2 targets...
notice: found boost-build.jam at /private/tmp/kbelco/boost/boost-
notice: loading Boost.Build from /private/tmp/kbelco/boost/tools_bb
notice: Searching /etc /home/kbelco /private/tmp/kbelco/boost/
tools_bb /private/tmp/kbelco/boost /private/tmp/kbelco/boost/
tools_bb /private/tmp/kbelco/boost/tools_bb/kernel /private/tmp/
kbelco/boost/tools_bb/util /private/tmp/kbelco/boost/tools_bb/build /
private/tmp/kbelco/boost/tools_bb/tools /private/tmp/kbelco/boost/
tools_bb/contrib /private/tmp/kbelco/boost/tools_bb/. for site-config
configuration file site-config.jam .
notice: Loading site-config configuration file site-config.jam from /
private/tmp/kbelco/boost/tools_bb/site-config.jam .
notice: Searching /home/kbelco /private/tmp/kbelco/boost/tools_bb /
private/tmp/kbelco/boost /private/tmp/kbelco/boost/tools_bb /private/
tmp/kbelco/boost/tools_bb/kernel /private/tmp/kbelco/boost/tools_bb/
util /private/tmp/kbelco/boost/tools_bb/build /private/tmp/kbelco/
boost/tools_bb/tools /private/tmp/kbelco/boost/tools_bb/contrib /
private/tmp/kbelco/boost/tools_bb/. for user-config configuration
file user-config.jam .
notice: Loading user-config configuration file user-config.jam from /
private/tmp/kbelco/boost/tools_bb/user-config.jam .
notice: [python-cfg] Configuring python...
notice: [python-cfg] user-specified version: "2.3"
notice: [python-cfg] user-specified cmd-or-prefix: "/usr/bin/python"
notice: [python-cfg] Checking interpreter command "/usr/bin/python"...
notice: [python-cfg] running command '"/usr/bin/python" -c "from sys
import *; print 'version=%d.%d\nplatform=%s\nprefix=%s\nexec_prefix=%s
\nexecutable=%s' % (version_info[0],version_info
[1],platform,prefix,exec_prefix,executable)" 2>&1'
notice: [python-cfg] ...version mismatch (looking for 2.3 but found 2.5)
notice: [python-cfg] Details of this Python configuration:
notice: [python-cfg] interpreter command: "/usr/bin/python"
notice: [python-cfg] include path: "/include/python2.3"
notice: [python-cfg] library path: "/lib/python2.3/config" "/lib"
notice: [python-cfg] no framework directory found; using library path
/private/tmp/kbelco/boost/tools_bb/build/toolset.jam:461: in
IMPORT error: rule "" unknown in module "gcc."
/private/tmp/kbelco/boost/tools_bb/tools/darwin.jam:57: in load
/private/tmp/kbelco/boost/tools_bb/kernel/modules.jam:283: in import
/private/tmp/kbelco/boost/tools_bb/build/toolset.jam:37: in using
/private/tmp/kbelco/boost/tools_bb/user-config.jam:25: in modules.load
/private/tmp/kbelco/boost/tools_bb/build-system.jam:241: in load-config
/private/tmp/kbelco/boost/tools_bb/build-system.jam:383: in load-
/private/tmp/kbelco/boost/tools_bb/build-system.jam:520: in load
/private/tmp/kbelco/boost/tools_bb/kernel/modules.jam:283: in import
/private/tmp/kbelco/boost/tools_bb/kernel/bootstrap.jam:128: in boost-
/private/tmp/kbelco/boost/boost-build.jam:17: in module scope

-- Noel

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at