Boost logo

Boost-Build :

Subject: [Boost-build] Error generating .obj from .rc files using intel-win
From: Jan Boehme (jan.boehme_at_[hidden])
Date: 2008-11-23 09:00:00


I'm surprised no one stated a comment on this issue so far 'cause the
used compiler belongs to Boost's additional test compilers. I post this
again 'cause it's not listed in the gmane searchable archives.

# Jamfile
obj res : ABQPP.rc ;

built with bjam -q -d2 toolset=intel res gave me:

Error: ambiguity found when searching for best transformation
Trying to produce type 'OBJ' from:

  - { ABQPP.rc.RC }
Generators that succeeded:
  - rc.compile.resource
  - intel-win.compile.rc
First generator produced:
  - { rc%rc.compile.resource-res_res.obj.OBJ { ABQPP.rc.RC } }
Second generator produced:

  - { intel-win%intel-win.compile.rc-res_res.obj.OBJ { ABQPP.rc.RC } }

I also tried
obj res : ABQPP.rc : : <toolset>msvc : ;
to set the default build option but it didn't work too and resulted in
the same error message.

Used tools:
Boost.Build V2 (Milestone 12)
Boost.Jam 03.1.16
WIndows XP
MS Visual Studio 2005
Intel C++ 10.1.025

Any hints how to solve this issue?

Many thanks,

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at