Boost logo

Boost-Build :

Subject: Re: [Boost-build] bjam fails while building boost.python
From: Vladimir Prus (ghost_at_[hidden])
Date: 2009-05-12 15:22:01

On Monday 11 May 2009 20:52:33 Aamir Ahmed Khan wrote:
> I am compiling boost.python libraries by following the procedure given at
> I first configure the build and installation using script
> $ ./ --with-python=/usr/bin/python2.5 --with-libraries=python
> --prefix=~/work/boost/setup/boost_1_39_0/mybuild
> The output of script instructs me to run ./bjam to build while
> instructions at the above link say to run ./bjam install
> Anyways, I tried both the options but every time I get the same error
> Class top-level-target already defined
> Aborted

Can you open Jamroot and see how many lines of the form:

        class top-level-target : alias-target-class

you have? If more than one, your Jamroot is busted. Do you have,
in root source dir, files named [Jj]jamroot.jam, or project-root.jam?

If nothing works, add --debug-loading to bjam command line and
post the output.

- Volodya

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at