Boost logo

Boost-Build :

Subject: Re: [Boost-build] bjam command hangs
From: Michael Alexeev (michael.alexeev_at_[hidden])
Date: 2009-12-14 20:54:27

Hi Volodya,

On Mon, Dec 14, 2009 at 1:27 AM, Vladimir Prus <ghost_at_[hidden]> wrote:
> On Monday 14 December 2009 05:44:32 Michael Alexeev wrote:
>> The problem is that bjam never returns. I have to kill the process
>> manually. Also any other bjam command does not produce any output at
>> all and  simply hangs.
>> Does anybody else experience similar problem? Any help is greatly appreciated.
> Could you attach to hanged bjam with a debugger and get a backtrace?
> - Volodya
> _______________________________________________
> Unsubscribe & other changes:

It's weird, but I can't attach the debugger to the bjam process: the
gdb hangs itself.

boost_1_40_0> ./bjam --show-libraries

mike_at_linux-4b3g:~> ps -fu mike | grep bjam
mike 4052 3845 0 19:11 pts/3 00:00:00 ./bjam --show-libraries

mike_at_linux-4b3g:~> gdb
GNU gdb (GDB; openSUSE 11.1)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-suse-linux".
For bug reporting instructions, please see:
(gdb) attach 4052
Attaching to process 4052

This is it. No more output is produced. Starting bjam from the gdb
didn't help either:

(gdb) file bjam
Reading symbols from
debugging symbols found)...done.
(gdb) set args "--show-libraries"
(gdb) run
Starting program:
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

On the other hand I am not sure that it's a problem with the
boost.1.40 I tried 1.39.0 version and got the same result.


Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at