Boost logo

Boost-Build :

Subject: Re: [Boost-build] Boost build 1.42 broken on HPUX
From: Vladimir Prus (ghost_at_[hidden])
Date: 2010-03-29 15:29:03

Avi Bahra wrote:
> When transition to 1.39 ->1.42 on Linux I ran
> into a problem with building. I was told that it
> was a bug in boost build, which was fixed in
> the latest nightly build.
> I downloaded the new build, and replaced:
> <boost-root>/tools/build/v2
> This worked on Linux.
> Now I am finding the same problem on HPUX,
> i.e
> error: Unable to find file or target named
> error:
> '/scratch/ma/emos/ma0/hpia64/boost/boost_1_42_0/stage/lib/libboost_date_time-mt.a'
> error: referred from project at
> error: ''
> When I tried using the new boost build I get:
> itanium{/scratch/ma/emos/ma0/hpia64/boost/boost_1_42_0}:! --> bjam
> notice: no Python configured in user-config.jam
> notice: will use default configuration
> /scratch/ma/emos/ma0/hpia64/boost/boost_1_42_0/Jamroot:637: in modules.load
> rule targets.create-metatarget unknown in module

This function ('create-metatarget') was added in revision 52319, according to
'svn blame'. 1.42 was created from revision 59432. So, it looks like you have
somehow grabbed too old Boost.Build. Did you actually used nightly build?
There should be timestamp.txt inside the package, what is the content?

- Volodya

Boost-Build list run by bdawes at, david.abrahams at, gregod at, cpdaniel at, john at